Difference between revisions of "Inkscape kennsluefni"

From Fab Lab Wiki - by NMÍ Kvikan
Jump to: navigation, search
m (language bar fix)
(YouTube)
Line 11: Line 11:
 
[https://www.youtube.com/watch?v=dJ7BaDdEpQ0 Inkscape hönnun fyrir laserskurð]
 
[https://www.youtube.com/watch?v=dJ7BaDdEpQ0 Inkscape hönnun fyrir laserskurð]
  
 +
<iframe width="420" height="315" src="https://www.youtube.com/embed/dJ7BaDdEpQ0" frameborder="0" allowfullscreen></iframe>
  
 
== Algengar skipanir  ==
 
== Algengar skipanir  ==

Revision as of 15:03, 2 September 2015


Inkscape er frjálst vigrateikniforrit sem gerir það mjög auðvelt að búa til og vinna með vigurteikningar. Vigurteikningar eru gjarnan notaðar frekar en rastermyndir vegna þess að hægt er að stækka þær og minnka án þess að gæði tapist.

Inkscape er hægt að nálgast frítt á vefsíðu þess, www.inkscape.org, fyrir Linux, MacOS X og Windows. Einnig geturðu náð í kóðann að forritinu og breytt því að vild.


YouTube

Inkscape hönnun fyrir laserskurð

<iframe width="420" height="315" src="https://www.youtube.com/embed/dJ7BaDdEpQ0" frameborder="0" allowfullscreen></iframe>

Algengar skipanir

<video type="youtube">dJ7BaDdEpQ0</video> <video type="vimeo">28957984</video>

Stilling á stærð síðu: File > Document Properties

  • Hægt að velja stærðarmælikvarða (px, mm, cm o.s.frv.)
  • Width (vídd (x ás) (hægt að velja stærð og stærðarmælikvarða (px, mm, cm o.s.frv.)
  • Height(hæð (y ás) (hægt að velja stærð og stærðarmælikvarða (px, mm, cm o.s.frv.)
Transform1.png
Breyta stærð eða lögun hluta Object > Transform
  • Hægt að velja stærðarmælikvarða (%, px, mm, cm o.s.frv.)
  • Hægt að færa hluti (move)
  • Hægt að skala upp og niður til að breyta stærð (Scale)
    • Ath haka við Scale proportionally til þess að skala í réttum hlutföllum.
  • Snúa (rotate) (mælikvarði: deg (gráður))
  • Smella á Apply

Stýra fyllingum og útlínum Object > Fill & Stroke

  • Fylling inni í hlut: (Fill)
  • Gerð útlína og litur: Stroke Paint
  • Þykkt útlína: Stroke Style
    • Ath fyrir vektor skurð (skurð í gegnum efni í laser skera) þá þarf línan að vera skilgreind sem 0,01 mm á þykkt.

Flytja inn bitmap, jpg eða gif mynd og breyta í vektor

  • Byrjið að flytja inn mynd, File > Import > Open
  • Veljið Path > Trace Bitmap

Hægt er að prófa sig áfram með stillingar á Brightness cutoff, Edge detection, Colour quantization. Smellið á Update og þá sést hvernig myndin og útlínur breytast. Síðan er smellt á Ok.

Vista myndir

  • Vistið myndir sem .svg, File > Save AS > svg Inkscape
  • Vistið myndir sem .pdf, File > Save As > PDF via Cairo (*.pdf)
Ábenging !! Best er að vista oft því Inkscape er mjög ungt forrit og gæti átt það til að hrynja – öll forrit geta hrunið!
Save .png
Document properties1.png
Þegar Inkscape er ræst upp birtist gluggi með fjölmörgum tökkum (mynd 1). Auk þeirra takka sem finna má í flestum forritum (svo sem nýtt skjal, opna, vista, prenta, o.þ.h.,) þá má sjá tvær tækjastikur, litastiku og svo striga fyrir miðju, en á hann teiknum við.


Breyta stærð skjalsins

Hægt er að breyta uppsetningu strigans með því að velja File → Document Properties.

Ef smellt er Fit page to selection mun striginn passa utan um hlutinn. Hér má einnig breyta strigastærð. Hægt er að velja ákveðna stærð í Pace size eða setja inn stærð í Custom size. Þar má breyta stærðarmælikvarðanum (%, px)mm, cm o.s.frv.) Width er vídd (x-ás), Height er hæð (y-ás)

Flakk um strigann

Það eru margar aðferðir til að flakka um strigann. Með því að nota Ctrl+örvatakka er hægt að færa sig til vinstri og hægri, upp og niður, með lyklaborðinu. Þú getur einnig dregið strigann til með því að halda inni miðjutakkanum á músinni (eða skrunhnappnum). Hægt er að nota skrunhnappinn á músinni til að færa sig upp og niður, en hægt er að fara til hægri og vinstri með því að halda Shift inni meðan þú skrunar.

Svo eru að sjálfsögðu skrunslár hægra megin og neðst á svæðinu þar sem striginn birtist. Hægt er að birta þá eða fela þá með því að ýta á Ctrl+B.

Til að þysja inn og út (zoom) geturðu notað og + takkanna á lyklaborðinu. Þú getur líka notað Ctrl+ miðjusmell á músinni eða Ctrl+ hægrismell til að þysja inn, og Shift+ miðjusmell eða Shift+ hægrismell til að þysja út. Auðveldast er þó sennilega að nota Ctrl+ skrunhnappinn.

Neðst í glugganum hægra megin er reitur sem stendur “Z:” fyrir framan. Þar geturðu stillt nákvæma þysingu í prósentum.

Verkfærastikurnar

Tvær láréttar verkfærastikur eru efst. Sú efri er með flýtivísa fyrir algengar aðgerðir en sú neðri (stjórnstikan) er breytileg eftir því hvaða tól er verið að nota. Tólin eru valin úr lóðréttu verkfærastikunni vinstra megin, en hún sýnir öll helstu tólin sem Inkscape hefur til að teikna og vinna með myndir.

Neðst í glugganum er stöðuslá sem gefur þér vísbendingar og upplýsingar meðan þú vinnur.

Flestar aðgerðir eru aðgengilegar í gegnum lyklaborðið. Ekki er nauðsynlegt að læra þær flýtivísanir, en það að þekkja þær sem þú notar oftast getur hraðað verulega á vinnunni þinni. Nokkrar einfaldar eru:

F1 eða s		Veljari
Bilstöng		Tímabundinn veljari (ýttu aftur til að fá tólið sem þú varst með)
F2, n			Hnútabreytingar
Shift+F2, w		Fiffingar
F3, z			Þysja
F4, r			Teikna rétthyrning
Shift+F4, x		Teikna þrívíðan kubb
F5, e			Teikna ellipsu eða boga
F6, p			Fríhendisteikning með blýanti
Shift+F6, b		Bezier-ræmur með penna
Ctrl+F6, c		Skrautskrift
Shift+F7, u		Málnignarfata
Ctrl+F1, g		Litastigull
F7, d			Litaveljari
F8, t			Texti
F9, i			Spíralar
Shift+F9, *		Stjörnur
Ctrl+F2, o		Tengingar

Help → Keys and Mouse gefa fulla útlistun á þessu. Farið verður í það svo hvað hvert tól gerir hér á eftir.

Að búa til og vinna með skjöl

Inkscape vinnur þannig með myndir að hvert skjal inniheldur einn striga, og á striganum er svo myndin. Inkscape notar SVG sem gagnasnið, en SVG er byggt á XML, rétt eins og vefsíður á Internetinu. SVG myndir er orðið hægt að nota beint á Internetinu með sama hætti og vefsíður, þar sem flestir vafrar kunna orðið að lesa SVG skjöl. En XML skjöl er erfitt að lesa, og því er það oft þannig að ef nota á vigramyndir í öðrum tilgangi en á netinu er best að flytja þær út úr forritinu yfir í önnur snið sem er auðveldara að túlka, til dæmis EPS, PNG, AI eða DXF.

Til að búa til nýtt tómt skjal geturðu valið File → New, eða Ctrl+N. Til að opna SVG skjal sem er til notarðu File → Open, eða Ctrl+O.

Einföld form

Jæja. Þá er orðið tímabært að teikna! Smelltu á rétthyrningstólið í verkfærastikunni (eða ýttu á F4) og smelltu og dragðu innan strigans.

Error creating thumbnail: Unable to save thumbnail to destination

Kassarnir verða bláir með svörtum útlínum, og þeir eru pínulítið gegnsæir. Prófaðu núna hin formtólin, sem gera hringi og sporöskjur, stjörnur og spírala.

Error creating thumbnail: Unable to save thumbnail to destination

Þegar þú býrð til form sjást einn eða fleiri demantar í kringum formið. Prófaðu að smella á þá og draga, og sjáðu hvernig formið bregst við. Stjórnstikan leyfir þér einnig að hafa áhrif á formið.

Þegar þú breytir stillingum á tilteknu formi, þá taka þær stillingar gildi á nýjum formum sem þú býrð til. Ef þú býrð til bláan kassa, og gerir hann svo rauðan, þá er næsti kassi sem þú gerir líka rauður.

Til að taka til baka síðustu aðgerð geturðu notað Ctrl+Z. Ef að þú skiptir svo um skoðun, og villt að sú aðgerð gildi, geturðu notað Shift+Ctrl+Z.

Færsla, skölun og snúningur

Þegar unnið er með vigra eru þrjár grunnaðgerðir sem hægt er að gera. Farið verður seinna í nákvæmlega hvernig þær virka, en hér ætlum við bara að skoða hvernig þær virka í Inkscape.

Það tól sem við notum oftast í Inkscape er veljarinn. Þú getur valið hann með F1, eða efsta takkanum í tólastikunni (sem lítur út eins og ör). Einnig geturðu notað bilstöngina til að velja veljarann tímabundið, og þá geturðu ýtt aftur á bilstöngina til að fá það tól sem þú varst með áður.

Með veljaranum geturðu valið hvað sem er á striganum. Prófaðu að smella á einhvern rétthyrninginn. Þá birtist punktalína umhverfis rétthyrninginn og átta örvar umhverfis hann. Nú getur þú:

  • Fært hann til með því að draga hann. Þú getur haldið Ctrl inni til að leyfa bara lárétta eða lóðrétta færslu.
  • Skalað hann með þvi að draga örvarnar. Haltu Ctrl inni til að viðhalda hlutfalli milli hæðar og breiddar.

Smelltu nú aftur á rétthyrninginn. Þá hefurðu smellt tvisvar á hann, og örvarnar breytast. Nú getur þú:

  • Snúið hlutnum með því að draga örvarnar í hornunum. Haltu Ctrl inni til að láta hann snúast í 15° skrefum. Krossinn í miðjunni á hlutnum má færa til að breyta viðmiðunarpunktnum sem hluturinn snýst eftir.
  • Skekkt hlutinn með því að draga örvarnar á hliðunum. Haltu Ctrl inni til að láta hann skekkjast í 15° skrefum.

Meðan þú ert með veljarann valinn geturðu líka notað stjórnstikuna til að ákveða nákvæm gildi á staðsetningu, hæð og breidd hlutarins.

Umbreytingar með lyklaborðinu

Eitt sem gerir Inkscape ólíkt flestum vigrateikniforritum er áherslan á að geta gert allt með lyklaborðinu. Það eru mjög fáar skipanir sem er ómögulegt að framkvæma með lyklaborðinu, og umbreytingarnar sem við töluðum um hér á undan eru engin undantekning.

Þú getur notað lyklaborðið til að færa (með örvatökkunum), skala (með < og > tökkunum), og snúa hlutum (með [ og ] tökkunum).

Að jafnaði færast hlutir og skalast um 2 pixel í einu. Ef þú heldur shift inni geturðu fært og skalað um tífallt það (20 pixel). Ctrl+> og Ctrl+< skala upp í 200% eða niður í 50% miðað við upprunalega stærð. Snúningur er um 15° í senn, en með því að halda Ctrl inni geturðu snúið um 90°.

Til að ná nákvæmustu breytingum þarftu gjarnan að gera breytingar eitt pixel í einu, en það er gert með því að halda Alt inni. Alt+örvatakkarnir færa valinn hlut um 1 pixel miðað við núverandi þysjun. Þetta þýðir að tilfærslan verður minni (og nákvæmari) eftir því sem þú þysjar meira inn. Fyrir vikið er hægt að staðsetja hluti með eins mikilli nákvæmni og vera skal, bara með því að þysja meira og meira inn.

Að sama skapi notar maður Alt+> og Alt+< til að skala valin form þannig að sýnileg stærð breytist um einn pixel á skjánum. Alt+] og Alt+[ snúa hlutnum þannig að sá punktur sem er fjarlægastur miðjunni hreyfist um einn pixel á skjánum.

Að velja mörg form í einu

Þú getur valið marga hluti í einu með því að halda Shift inni og smella á þá. Þú getur dregið kassa umhverfis þá hluti sem þú ætlar að velja; þetta er kallað teygjuval. Veljarinn gerir teygju umhverfis hluti þegar þú dregur frá auðum reit á striganum – ef þú byrjar að draga frá ofan á hlut, þá lendirðu í því að hluturinn verður valinn og færist til, sem er ekki það sem þú villt að gerist. Til að komast hjá þessu geturðu haldið shift inni áður en þú byrjar að draga, og þá býr Inkscape alltaf til teygju. Prófaðu þig áfram með þessu til að ná tækninni, til dæmis með myndum á borð við þessi:

Error creating thumbnail: Unable to save thumbnail to destination

Sérhver hlutur sem er valinn er með punktalínu umhverfis sig. Þessi punktalína hjálpar þér að sjá hvað er valið og hvað ekki. Til dæmis, ef þú myndir velja sporöskjurnar og ferninginn undir þeim hér að ofan væri erfitt að sjá hvað væri valið og hvað ekki ef ekki væri fyrir punktalínurnar.

Ef að þú heldur Shift inni og smellir á hlut sem er valinn, þá hættirðu að velja hann. Þannig, ef þú ert með marga hluti valda (til dæmis öll formin að ofan) en villt hætta að velja einhvern einn þeirra (til dæmis stjörnuna), þá geturðu notað Shift+smell til að taka þann hlut út úr valinu meðan þú heldur hinu eftir.

Þú getur ýtt á Esc til að afvelja alla hluti. Ctrl+A velur alla hluti í núverandi lagi (layer). Ef að þú bjóst ekki til nein lög, þá eru allir hlutir í sama lagi og þá velur þetta alla hluti í skjalinu.

Hópar

Marga hluti má sameina í einn hóp. Hópar hegða sér eins og einn hlutur þegar þú sýslar með þá; þannig geturðu tryggt það að allar breytingar á einum hlut í hópnum hafi áhrif á alla hlutina í hópnum.

Til að búa til hóp, veldu einn eða fleiri hluti og ýttu á Ctrl+G (eða Object → Group). Til að brjóta hóp upp í einingar sínar, veldu hópinn og ýttu á Ctrl+U (eða Object → Ungroup). Hægt er að hópa saman hópa, og hópa þá saman við aðra hópa, eins djúpt og þú villt. Hinsvegar hefur afhópun bara áhrif á efsta hópinn í keðjunni, og til að afhópa dýpra þarftu að framkvæma aðgerðina oft.

Þú þarft hinsvegar ekki að brjóta hópa þótt þú viljir breyta einstökum hlut innan hópsins án þess að hafa áhrif á hina. Haltu bara Ctrl inni og smelltu á hlut til að velja hann óháð öllu hópafyrirkomulagi, eða Shift+Ctrl+smell til að velja fleiri en einn hlut innan eða utan hvaða hópa sem er. Prófaðu að færa eða breyta einstökum formum í hóp án þess að brjóta hópinn.

Fyllingar og útlínur

Error creating thumbnail: Unable to save thumbnail to destination

Mikið af aðgerðunum í Inkscape fara fram í gegnum þar til gerða glugga. Einfaldasta leiðin til að breyta um lit á einhverjum hlut er að velja hlutinn og velja svo litinn úr litaröndinni neðst. Einnig er hægt að velja útlínulit með því að hægrismella á litaröndina.

Fylling (Fill), Útlínur (Stroke Paint)

Öflugara tól til að breyta litum er Fill and Stroke valmyndin (Shift+Ctrl+F). Þar sérðu þrjá flipa: Fill, Stroke paint, og Stroke style.

Fill and Stroke valmynd


Fill flipinn stýrir fyllingu hluta. Þar geturðu valið um enga fyllingu, heilan lit, tvennskonar litastigla (gradient) eða mynstur. Auk þess geturðu stýrt gegnsæi (opacity) og bjaga (blur) hlutarins. Fiktaðu þig aðeins áfram með þetta.

Ef þú ert með heilan lit (flat fill) valið þá hefður nokkrar aðferðir til að velja lit: RGB, HSL, CMYK og Wheel (litahjólið). Auðveldast er að nota litahjólið ef þú villt velja eftir auganu, en þá snýrðu þríhyrningnum til að velja litablæ, og svo færirðu punktinn til innan þríhyrningsins til að velja tón. Allir litaveljararnir eru með renning neðst þar sem þú ræður gegnsæi litarins.

Til að velja liti með nákvæmari hætti geturðu notað RGB, HSL eða CMYK litaveljarana. CMYK er mikið notaður í prentiðnaðinum, RGB á vefnum, og HSL í ljósmyndavinnslu, en hægt er að ná fram sömu litunum með öllum aðferðunum. Prófaðu þig endilega áfram; færni í litavali kemur bara með reynslunni.

Þegar þú velur hlut er litaveljarinn uppfærður til að sýna núverandi fyllingu og útlínu. Ef að þú ert með marga hluti valda sýnir valmyndin meðaltalið af litunum þeirra.

Error creating thumbnail: Unable to save thumbnail to destination

Með því að nota Stroke flipann geturðu fjarlægt útlínur hlutarins eða gefið þeim hvaða lit eða gegnsæi sem er:

Error creating thumbnail: Unable to save thumbnail to destination

Í síðasta flipanum, Stroke style, geturðu stillt þykkt útlínanna og ýmsa aðra valkosti:

Error creating thumbnail: Unable to save thumbnail to destination

Að lokum, þá geturðu valið litastigla í staðinn fyrir heila liti bæði á fyllingum og útlínum:

Error creating thumbnail: Unable to save thumbnail to destination

Þegar þú skiptir frá heilum lit yfir í litastigul tekur stigullinn litinn sem hafði áður verið valinn, með stefnu frá heilum að gegnsæum. Ef þú skiptir yfir í stigulstólið (Ctrl+F1) geturðu dregið stýringuna fyrir stigulinn – lína sem segir til um upphaf, stefnu og lengd stigulsins. Þegar eitthvert haldfanganna er valið sýnir litavalsvalmyndin lit þess haldfangs frekar en lit alls hlutarins sem unnið er með.

Enn ein leið til að breyta lit hlutar er með litaveljaranum (F7). Með því að smella hvar sem er í teikningunni með því tóli tekur hluturinn þann lit sem fyllingu. (Shift+smell) setur litinn á útlínurnar.
Stilling á útlínum fyrir vektorskurð 0,01mm.

ATH! fyrir vektorskurð er mjög mikilvægt að smella á Stroke style og stilla á 0,01mm eins og sýnt er á myndinni hér til hliðar.

Vektormynd

Ef breyta á jpg-, gif- eða bitmap myndum í vektormynd er smellt á myndina og síðan á Path > Trace Bitmap > Update og síðan er smellt á OK (Shift+Alt+B) Hægt er að prófa sig áfram með stillingar á Brightness cutoff, Edge detection og Colour quantization. Ef smellt er á Update sést hvernig myndin og útlínur breytast. Ef hakað er við Invert image snýst liturinn í myndinni, ljósa svæðið verður dökkt og dökka verður ljóst. Þegar búið er að smella á OK eru myndirnar orðnar tvær, önnur er vektormynd en hin er svokölluð rastermynd. Hægt er að draga myndirnar í sundur með pílunni vinstra megin (veljarinn) eða nota örvatakkana. Ef smellt er á myndirnar og svo á litastikuna neðst á síðunni, fær önnur myndin lit. Sú sem fær lit er vektormyndin sem vinna á með í Inkscape. Hinni myndinni má eyða með því að smella á Delete á lyklaborðinu.

Afritun, röðun og dreifing

Röðunargluggi. Hér er valið eftir stærsta hlutnum (Biggest item) og miðjað.

Eitt af því sem er mjög mikið gert er að hlutir eru afritaðir (Ctrl+D). Afritið er sett nákvæmlega fyrir ofan það sem afritað var, þannig að þú getur fært það til með því að nota músina eða örvatakkana.



Oft þarf að raða hlutum. Þá kemur röðunarglugginn (Ctrl+Shift+A) að gagni. Veldu alla hlutina sem þú villt raða (Shift+smell eða notaðu teygju) og opnaðu gluggann til að fá ýmsa valkosti varðandi röðun hluta. Þá geturðu til dæmis valið “Center on horizontal axis” takkann til að láta alla hlutina raða sér á sama lóðrétta ásinn, eða “Make horizontal gaps between objects equal” takkann til að dreifa þeim um lóðrétta ásinn. (Nöfn takkanna birtast ef þú bíður með músina yfir takkanum í smá stund án þess að hreyfa hann eða smella).

Ef þú smellir fyrst á annann, svo á hinn, verða hlutirnir raðaðir vel og þeir verða með jafnt bil sín á milli. Hér eru nokkur dæmi um hvernig röðun og dreifingu þú getur náð fram:

Error creating thumbnail: Unable to save thumbnail to destination

Z-röðun

Hugtakið z-röðun er notað til að merkja sú röð sem hlutirnir staflast ofan á hvern annan í teikningunni; þ.e., hvaða hlutir eru ofan á og skyggja þá á hina. Nokkrar skipannir eru til til að breyta þessari röðun.

Tvær skipannir í Object valmyndinni, Object → Raise to Top (Home) og Object → Lower to Bottom (End) færa hlutina sem þú hefur valda alveg efst eða alveg neðst í z-röðinni.

Error creating thumbnail: Unable to save thumbnail to destination

Tvær aðrar: Object → Raise (Page Up) og Object → Lower (Page Down) sökkva hlutnum eða reisa hann um eitt skref í z-röðinni.

Mjög nytsamlegur flýtivísir er Tab takkinn. Ef ekkert er valið lætur hann neðsta hlutinn í teikningunni vera valinn, annars velur hann hlutinn fyrir ofan valda hlutinn í z-röðinni. Shift+Tab virkar í hina áttina: ef ekkert er valið velur hann efsta hlutinn, annars vinnur hann sig niður. Þar sem að ný form eru alltaf sett efst þá gefur Shift+Tab þér alltaf beinan aðgang að þeim hlut sem þú bjóst til síðast.

Undirval og færsla

Hvað gerirðu ef að hluturinn sem þú villt velja er undir öðrum hlut? Þú sérð hann kannski ef að sá sem er ofan á er að hluta til gegnsær, en þegar þú smellir á hann færðu efri hlutinn, ekki þann sem þú þarfnast.

Þá kemur Alt+smell að gagni. Fyrsta Alt+smell velur efsta hlutinn eins og venjulegt smell, en næst þegar þú gerir Alt+smell á sama stað velst hluturinn fyrir neðan þann efsta; svo enn neðar og koll af kolli. Ef að þú ferð lengra en neðsta hlutinn þá velst sá efsti aftur.

Þegar þú hefur réttan hlut valinn geturðu gert allar umbreytingar á honum með lyklaborðinu, en ef að þú ætlar að draga hann til með músinni þarftu að gæta þín – ef þú byrjar að draga, þá velst efsti hluturinn aftur og hann dregst til. Til að segja Inkscape að færa frekar til það sem er valið nú þegar, haltu þá Alt takkanum niðri og dragðu.

Error creating thumbnail: Unable to save thumbnail to destination

Nánar um afritun

Eftir að þú afritar hluti (Edit → Copy eða Ctrl+C) eða skerð þá burt (Edit → Cut eða Ctrl+X) lætur líma skipunin (Edit → Paste eða Ctrl+V) hlutinn (eða afrit af honum) límast þar sem músarbendillinn er, eða, ef músarbendillinn er utan gluggans, á miðju strigans. Hinsvegar man hluturinn hvar hann var upprunalega, þannig að hægt er að líma hann á sinn stað með Ctrl+Alt+V.

Önnur skipun, líma stíl (Shift+Ctrl+V), lætur stílinn á fyrsta hlutnum sem afritaður var á þá hluti sem eru núna valdir. “Stíllinn” samanstendur af fyllingu, útlínum, og leturgerð en ekki lögun, stærð eða öðrum hlutum sem snúa að forminu svo sem fjölda odda á stjörnu.

Gættu þess að Inkscape notar sitt eigið innbyggða klippispjald og afritar hluti ekki á klippispjald stýrikerfisins nema þegar um texta er að ræða.

Fríhendisteikning og reglulegir ferlar

Auðveldasta leiðin til að teikna ferla fríhendis er með blýantstólinu (F6):

Error creating thumbnail: Unable to save thumbnail to destination

Ef þú villt teikna reglulegri form, notaðu þá pennann (Shift+F6):

Error creating thumbnail: Unable to save thumbnail to destination

Þegar þú notar pennatólið þá verður til “beittur” hornpunktur í hvert skipti sem þú smellir, þannig að þú færð nokkrar beinar línur með því að smella nokkrum sinnum. Ef þú smellir og dregur verður til mjúkur Bezier-hornpunktur með tveimur haldföngum á ímyndaðri línu (sem þér er sýnd þegar þú ert að vinna með hlutinn). Haltu Shift meðan þú dregur haldfang til að snúa bara annað þeirra og halda hinu kyrru. Eins og venjulega takmarkar Ctrl stefnubreytingar (ýmist á beinum línum eða á Bezier haldföngum) við 15 gráðu skref. Ef þú ýtir á Enter klárast línan, en Esc hættir við línuna. Til að hætta við bara síðasta hluta ókláraðrar línu, notaðu Backspace.

Bæði í fríhendis- og Bezier tólunum sýnir valinn ferill litla ferkantaða kassa á báðum endum. Þetta kallast akkeri, og leyfa þér að halda áfram með línuna (með því að teikna áfram frá akkerinu) eða loka línunni (með því að teikna frá öðru akkerinu að hinu).

Breytingar á ferlum

Ólíkt formunum sem formtólin búa til búa blýants- og pennatólin til ferla. Ferill er runa af beinum línustrikum eða Bézier-línum sem, líkt og allir aðrir hlutir í Inkscape, geta haft ýmsar stillingar á fyllingu og útlínum. En ólíkt reglulegum formum má breyta ferli með því að draga hnúta eða hornpunkta ferilsins til, en ekki bara fyrirfram skilgreind haldföng.

Error creating thumbnail: Unable to save thumbnail to destination

Ef þú velur feril og velur svo hnútatólið (F2) sérðu gráa reiti birtast á ferlinum, þetta eru hnútarnir. Þú getur valið þá með því að smella, Shift+smella eða draga teygju umhverfis þá, rétt eins og hlutir eru valdir með veljaranum. Valdir hnútar lýsast upp og sýna haldföngin sín, einn eða tveir litlir hringir sem eru tengdir við hnútinn með beinum línum.

Þú getur dregið hnútana og haldföngin þeirra til. Ctrl notast eins og vanalega til að takmarka hreyfingu og snúning. Örvatakkarnir, Tab, [, ], <, > ásamt breytingartökkunum (Ctrl, Shift og Alt) gera það sama og þeir gera með veljaranum, en eiga þá við um hnútana í staðinn fyrir hlutina sem heild. Þú getur eytt (Del) eða fjölfaldað (Shift+D) valda hnúta. Þú getur brotið ferilinn (Shift+B) á völdum hnút, eða ef þú hefur valið tvo endahnúta á sama ferlinum geturðu sameinað þá (Shift+J).

Hnútur getur verið broddur (Shift+C), sem þýðir að haldföng þess geta gengið sjálfstætt í hvaða horni sem er; þjáll (Shift+S), sem þýðir að haldföngin eru alltaf á sömu beinu línunni (samlína); eða samhverfur (Shift+Y), sem er sama og þjáll hnútur nema hvað haldföngin hafa sömu lengd.

Þú getur þar að auki dregið haldföng hnúts inn alfarið með því að halda Ctrl og smella á hann. Ef tveir samliggjandi hnútar eru með haldföngin dregin inn verður línan milli þeirra að beinni línu. Til að draga haldföngin aftur út, haltu Shift inni og dragðu burt frá hnútnum.

Hlutferlar og sameining

Ferill getur innihaldið einn eða fleiri hlutferil. Hlutferill er runa af hnútum sem eru fastir saman. (Þar af leiðandi, ef að ferill hefur fleiri en einn hlutferil, þá eru ekki allir hnútar þess fastir saman.)

Error creating thumbnail: Unable to save thumbnail to destination

Þannig geturðu teiknað myndina að ofan með þremur aðgreindum ferlum eða einum ferli sem samanstendur af þremur hlutferlum. Taktu samt eftir því að ferill með mörgum hlutferlum er ekki það sama og hópur. Það er sér hlutur sem er eingöngu veljanlegur sem heild.

Inscape getur sameinað marga ferla í einn samsettan feril (Ctrl+K) eða brotið sundur sameinaðan feril í marga ferla (Shift+Ctrl+K).

Þar sem hlutur getur eingöngu haft eina fyllingu og eina stillingu á útlínum fá nýjir samsettir ferlar stílinn úr fyrsta ferlinum sem er verið að sameina við. Þegar þú sameinar ferla sem skerast sem hafa fyllingu mun að jafnaði fyllingin hverfa á þeim stöðum þar sem brautirnar skerast:

Mynd 17

Þetta er auðveldasta leiðin til að búa til hluti sem hafa göt. Ef þú villt fá öflugri stýringar á ferlum, skoðaðu Booleískar aðgerðir að neðan.

Að breyta í feril

Hvaða form eða texta sem er má breyta í feril (Shift+Ctrl+C). Þessi aðgerð breytir ekki útliti hlutarins, en hinsvegar fjarlægir það alla eiginleika sem tilheyra týpunni (til dæmis er ekki lengur hægt að rúna horn rétthyrnings eða breyta textanum). Þess í stað geturðu núna breytt hnútunum.

Mynd 18

Að auki geturðu breytt útlínum hvaða hlutar sem er í feril.

Mynd 19

Booleískar aðgerðir

Aðgerðirnar í Path valmyndinni leyfa þér að sameina tvo eða fleiri hluti með Booleískum aðgerðum:

Mynd 20

Flýtivísarnir fyrir þessar skipanir vísa til stærðfræðilegu hliðstæðna Booleísku aðgerðanna (sammengi er summa, mismunur er frádráttur, og þaðan af). Mismuns- og undanskilningsskipanirnar (difference og exclusion) geta bara átt við tvo valda hluti; aðrar skipanir geta átt við marga hluti í einu. Útkoman tekur alltaf stíl neðsta hlutarins (m.v. z-röðun).

Útkoman úr undanskilningsskipuninni (exclusion) lítur svipað út og sameina (sjá að ofan), en hann er ólíkur að því leytinu til að undanskilningur skilur eftir auka hnúta þar sem upprunalegu ferlarnir skerast. Munurinn milli deilingar (division) og skurðar (cut path) er að deiling sker neðri hlutinn með feril stærri hlutarins, en skurður sker bara útlínurnar og fjarlægir alla fyllingu.

Innsett og útsett

Inkscape getur stækkað og minnkað form ekki bara með skölun, heldur einnig með því að færa til feril hlutarins, þ.e., að færa hlutinn til samsíða ferlinum í hverjum punkti. Þessar skipanir eru kallaðar innsettning og útsetning. (Inset, Ctrl+( og útsett Ctrl+) ). Hér má sjá upprunalegan feril og fjöldan allan af ferlum sem eru innsettir eða útsettir úr upprunalega ferlinum:

Mynd 21

Innsetningar- og útsetningarskipanirnar búa til ferla (og breyta upprunalega hlutnum í feril ef hann er það ekki fyrir). Oft er hagkvæmara að nota hreyfanlega hliðrun (Dynamic Offset, Ctrl+J) sem býr til hlut með haldfang sem má draga sem má nota til að stýra hvar innsetningin eða útsetningin endar.

Mynd 22

Hreyfanleg hliðrun man hver upprunalegi ferillinn var, þannig að myndin verður ekki óskýrari eftir því sem þú breytir henni oftar. Þegar þú þarft ekki að breyta henni lengur geturðu alltaf breytt honum aftur í feril.

Enn nytsamlegara er tengd hliðrun, sem er svipað og hreyfanlega hliðrunin en er tengd við annan feril. Þú getur haft eins margar hliðranir tengdar við einn upprunaferil eins og vera skal. Fyrir neðan er upprunalegi ferillinn rauður, og annar tengdi ferillinn með svartar útlínur og enga fyllingu meðan hinn er með svarta fyllingu og engar útlínur.

Ef þú myndir breyta rauða ferlinum núna myndu báðir svörtu ferlarnir breytast á sambærilegan hátt. Nú geturðu valið hvaða hliðrun sem er og breytt hliðrunarradíusnum. Að lokum ættirðu að prófa að færa eða breyta upprunalega ferlinum og skoða hvaða áhrif það hefur á tengdu hlutina og hvernig þú getur hreyft og breytt tengdu ferlunum óháð upprunalega ferlinum án þess að missa tenginguna.

Mynd 23

Einföldun

Aðal notin fyrir einfalda skipunina (Ctrl+L) er að minnka fjölda hnúta í ferli á meðan þú viðheldur löguninni næstum því. Þetta er nytsamlegt fyrir ferla sem þú teiknar með blýantinum, þar sem að það tól býr gjarnan til fleiri hnúta en eru nauðsynlegir. Fyrir neðan var ferillinn til vinstri búinn til með blýantinum, en sá sem er hægra megin er afrit sem var einfaldað. Upprunalegi ferillinn hefur 28 hnúta, en einfaldaði ferillinn hefur 17 hnúta: þá er auðveldara að vinna með hann, og hann er þjálli.

Mynd 24

Hve mikið einfaldað er (kallað þröskuldurinn) er háð því hversu mikið er valið. Ef þú velur feril ásamt stærri hlut verður einföldunin mun grófari en ef þú myndir velja bara ferilinn. Að auki er hröðun í einföldunarskipuninni. Það þýðir að ef þú ýtir oft á Ctrl+L í röð (innan við 0.5 sekúndur af hvor öðru), hækkar þröskuldurinn í hvert skiptið. Ef þú bíður þá í eina sekúndu og einfaldar svo aftur er þröskuldurinn kominn á sinn upphafsstað aftur. Með því að nýta sér þessa hröðun geturðu stýrt einfölduninni eins og þú villt.

Það er hægt að nota einföldunina á listrænan hátt. Oft verða form sem eru hörð og rúmfræðileg mun fallegri og líflegri þegar þau eru einfölduð. Hörð horn bráðna og náttúrulegar bjaganir eiga sér stað; oft stílhrein og gjarnan fyndin. Hér er dæmi um listræna einföldun:

Mynd 25

Tannhjól

Til þess að gera tannhjól(gear) ferðu í effects>render>gear... Þá kemur upp gluggi sem leyfir þér að velja fjölda tanna(number of teeths), þvermál hringsins í pixlum (circular pitch)(ekki mælt frá enda tanna) og halla tannhjólanna(pressure angle).

Error creating thumbnail: Unable to save thumbnail to destination

Tannhjólið sem myndast úr stillingunum hér að ofan ætti að líta einhvernveginn svona út.

Error creating thumbnail: Unable to save thumbnail to destination

Mikilvægt er að halli tannhjóla sem eiga að passa saman sé sá sami.


Smellismíði

  • Við smellismíði, (pressfit) getur verið ákaflega gagnlegt að notast við Clone tool.
  • Leiðbeiningar í Inkscape varðandi fyllta stafi [1]
  • Leiðbeiningar í Inkscape varðandi vistun og frágang hönnunar [2]
  • Leiðbeiningar í Inkscape varðandi hönnun samsmelltra hluta [3]
  • Leiðbeiningar um teikniverkfæri í Inkscape [4]


Tenglar